Hosted Exchange Interruption
Incident Report for Real World Technology Solutions
Resolved
The incident has been resolved with a rolling component restart across some of the mailbox storage systems.
Posted Mar 15, 2019 - 13:14 AEDT
Identified
Engineers are investigating an issue affecting some Hosted Exchange customers. They may be unable to access their mailboxes at present.
Posted Mar 15, 2019 - 12:39 AEDT
This incident affected: Email Services (Hosted Exchange).