CloudPBX Desktop Softphone

Incident Report for Real World Technology Solutions

Resolved

Engineers have applied a fix and testing shows fully restored performance on the CloudPBX desktop application.
Posted Mar 20, 2026 - 11:37 AEDT

Identified

We are currently aware of delayed call connections with CloudPBX Desktop application. This is affecting both inbound and outbound calling.

Engineers are current working on a fix to restore full performance on the application.
Posted Mar 20, 2026 - 11:23 AEDT
This incident affected: Voice Services (CloudPBX).