CloudPBX intermittent registration issues

Incident Report for Real World Technology Solutions

Postmortem

Earlier this morning a backup process interrupted a database node as part of the CloudPBX system. In this database state, the database node continued to accept connections, but was unable to service them leading to stuck queries, updates and transactions. Because the node was acting like it was alive, the mechanisms that usually handle node failures did not work.

The affected node was taken offline and the underlying issues were addressed in relation to the backup process which caused the issue, and the node was recovered. In addition, we’ve identified an improved way of detecting node availability that covers all existing scenarios, including this one, and have implemented this.

The incident affected traffic on approximately 30% of requests on two CloudPBX home servers, approximately 4% of users.

Posted Jun 12, 2026 - 22:39 AEST

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 22:36 AEST

Monitoring

We have resolved a CloudPBX instability that affected client registration for a small number of requests and some data reporting.
Posted Jun 12, 2026 - 09:29 AEST
This incident affected: Voice Services (CloudPBX).